CTX203993
2016-04-19
1970-01-01
Following error message was recorded in NetScaler log files after an upgrade to NetScaler 10.5 59.11 build. Nov 25 16 ...

Symptoms or Error

Following error message was recorded in NetScaler log files after an upgrade to NetScaler 10.5 59.11 build.
Nov 25 16:14:53 BRRNL406 [1104]: Error = 80000004 in nsagg_process_stat_request , closing connection Nov 25 16:14:53 BRRNL406 [1104]: previous message repeated 0 times in last 300 seconds

Solution

Follow the workaround as mentioned below:
Step 1:
copy the nscollectmap.xml file in /var/log/db/default/ location from NetScaler box which is upgraded from the build 10.1. 129.15 (which do not have this issue) to the /var/log/db/default/ location to NetScaler box which has issue.

Step2 :
From NetScaler Command Line Interface enter the command: "disable reporting" -- before copying the file,
and
the command "enable reporting" --- after copying the nscollectmap.xml.
This will kill and restart the nscollect module, which will use the new ‘nscollectmap.xml’ file copied.

Citrix is working on the issue and it will be fixed in NetScaler upcoming release.
Issue id:TSK0610809

Note:[Updated]
The above process maynot work in every scenario .It recommended to do an upgrade.In case if immediate fix is needed please escalate the case
??
?? ?? ?? ?? ??
10.5(Checked)62+?? ??
11.0(Checked)65_7+(Checked)65.13
10.1(Checked)134_5+(Checked)134.6

Problem Cause

The ns.log warning msg?? ?? “<local0.warn> BRRNL406 [1104]: Error = 80000004 in nsagg_process_stat_request”?? --
?? is present because nscollect module tried requesting?? more than 256 counters value?? in one request to aggregator.Nscollector module request for the counter values?? based on the counter information defined in ‘nscollectmap.xml’?? file.?? The nscollectormap.xml?? ?? doesn’t change based on configuration.
??
This file is generated under few condition,
  1. If the nscollectmap.xml file is missing or corrupted?? in?? /var/log/db/default/ location.
  2. If there are more new counters defined,?? or?? xml version mismatch
??

Applicable Products


 

Join the conversation

Citrix Discussions

Open a case

Citrix Support

特别说明


本文来源为Citrix.com所有,翻译后版权归翻译者所有.如需转载请注明出处.

文档版本


.

广告招租


最新留言


.

广告招租


.