CTX203880
2016-04-14
1970-01-01
When attempting enrollment the results are inconsistent. May work OK or may fail with several different error messages on client. App Controller registration ...

Symptoms or Error

When attempting enrollment the results are inconsistent. The enrollment may work OK or may fail with several different error messages on client. App Controller registration works OK if you skip MDM.


Solution

Complete the following steps to troubleshoot this issue:

  1. Ensure that NetScaler VIP is listening on port 8443 and persistence is set to source IP??instead of least connection.

  2. Make the following changes in ewconfig.properites file, to not to delay enrollments:
    # delay (in ms) when first page appear
    ios.mdm.enrollment.firstStepDelay=4000
    # delay (in ms) for others steps (currently: step 2 after CA install)
    ios.mdm.enrollment.stepDelay=1000
    # last delay (in ms) before recall agent app
    ios.mdm.enrollment.lastStepDelay=2000

  3. Ensure that Android scheduler is changed from always connect to check-in every 6 hours.

  4. Disable SSL reuse for 443 and 8443 on the NetScaler. Additionally on the MDM VIP 8443, disable SSL Redirect and SSL Redirect Port Rewrite setting should be raised from 500 to 2000.


Problem Cause

Some of the NetScaler configuration was incorrect. Additionally, the MDM configuration required tweaking as per the environment.


Applicable Products


 

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