Symptoms or Error
The following errors or alerts might appear in??XenCenter:
-
File System on Control Domain Full.
-
Disk usage for the Control Domain on server 'XenServer' has reached 99.0%. XenServer's performance will be critically affected if this disk becomes full .
-
Log files or other non-essential (user created) files should be removed.
Impact on the environment
-
Performance of the VMs across the pool or host becomes sluggish.
-
Host becomes completely unresponsive.
-
XenServer console will show error:??"The XenAPI connection has timed out , the console will have reduced functionality".
-
All the Consoles, for hosts or VM,????become??unresponsive.
-
Error while trying to update hotfixes: "No space left on the device".
-
Any command or any process on the host ??takes too long to execute.
#df -h
Filesystem?????????????????????? Size?? Used Avail Use% Mounted on
/dev/sda2???????????????????????? 4.0G?? 3.6G?? 147M?? 97% /
none?????????????????????????????????? 2.0G???? 40K?? 2.0G???? 1% /dev/shm
/opt/xensource/packages/iso/XenCenter.iso
???????????????????????????????????????????? 52M???? 52M???????? 0 100% /var/xen/xc-install
/dev/mapper/XSLocalEXT--6e4fc08e--5459--ccbb--4959--2bccc93076ea-6e4fc08e--5459--ccbb--4959--2bccc93076ea
?????????????????????????????????????????? 542G?? 167G?? 347G?? 33% /var/run/sr-mount/6e4fc08e-5459-ccbb-4959-2bccc93076ea
Note: The highlighted percentage can vary from any value from 90 - 100.
Solution
Complete the following steps:
-
Remove additional Logs.
-
Remove??rogue entries of patch.
-
Remove??the patch-backups.
-
Review additional files.
Remove??additional Logs
- #cd /var/log
- #ls
- remove the logs using #rm -rf ??
Refer to the following screen shot for the complete command. This command ensures that all the current logs files will be intact and will not be deleted.
Remove??rogue entries of patch
-
#cd /var/patch
-
Remove all the entries except the??"/applied" folder??
Use the following command to remove all the rogue patches and without deleting the applied folder
?? ?? ??#ls | grep [0-9] |xargs rm -rfRemove the patch-backups
- cd /opt/xensource/patch-backup
- ls
- rm -rf *
Remove stunnel entries
???? ??. ?? ??# cd /tmp/
??
Note: If??these steps do not reflect the space being cleared,??run #service syslog restart and the usage inside the root file system will be cleared.
Review Additional files
-
Check /tmp directory for any rogue files. You can delete everything inside it as XenServer wont store any default files in it.
-
Check "~" and "/" to see if there are any additional ISO files or any extra packages??are present inside the directory.??If yes, delete them.
Even after executing all those above steps if the space is still not reclaimed, contact Citrix Technical support.
Problem Cause
-
Root??Partition??is filled up.
-
Rogue Entries of patches and log files.
Additional Resources
Disclaimer
Supporto Citrix
Traduzione automatica
Questo articolo ??¨ stato tradotto da un sistema di traduzione automatica e non ??¨ stata valutata da persone. Citrix fornisce traduzione automatica per aumentare l'accesso per supportare contenuti; tuttavia, articoli automaticamente tradotte possono possono contenere degli errori. Citrix non ??¨ responsabile di incongruenze, errori o danni derivanti dell'uso di articoli automaticamente tradotte.
Citrix技術支持
自動翻譯
這篇文章被翻譯由一個自動翻譯系統,並沒有受到人們的審查。 Citrix提供自動翻譯,增加獲得支持的內容;但是,自動翻譯的文章可能可以包含錯誤。思傑不負責不一致,錯誤或損壞因使用自動翻譯的文章的結果。
Поддержка Citrix
Tradução automática
Эта статья была переведена автоматической системой перевода и не был рассмотрен людьми. Citrix обеспечивает автоматический перевод с целью расширения доступа для поддержки контента; Однако, автоматически переведенные статьи могут может содержать ошибки. Citrix не несет ответственности за несоответствия, ошибки, или повреждения, возникшие в результате использования автоматически переведенных статей.
시트릭스 지원
자동 번역
이 문서 자동 번역 시스템에 의해 번역 된 사람들에 의해 검토되지 않았다. 시트릭스는 컨텐츠를 지원하기 위해 접근을 높이기 위해 자동 번역을 제공합니다; 그러나, 자동으로 번역 기사 오류를 포함 할 수있다. 시트릭스는 자동으로 번역 된 기사의 사용의 결과로 발생하는 불일치, 오류 또는 손해에 대해 책임을지지 않습니다.