CTX101931
XenApp
XenApp 5_0 for Windows Server 2008
Installation/Upgrade,Performance
2016-04-15
2014-04-23
Users receive an error message: “Error: 26008 Start IMA Service returned error in CTX_MF_IMA_StartIMAService Error = 1075 or 1068” while installing ...

Symptoms or Error

Users receive the following error message:

“Error: 26008 Start IMA Service returned error in CTX_MF_IMA_StartIMAService Error = 1075 or 1068” while installing XenApp.

Error Message

Steps to Reproduce

Complete the following steps to reproduce the issue ( MetaFrame Presentation Server 4.0 or Citrix Presentation Server 4.5 or XenApp 5.0):
  1. Build a Windows 2000 Service Pack 4 server or Windows 2003 Service Pack 1 server or Windows Server 2008.

  2. Stop the IPEC Policy Agent service for Windows 2000, or the IPSEC Services for Windows 2003, or IPsec Policy Agent for Windows Server 2008. Then set the service to disabled.

  3. Install MetaFrame Presentation Server 4.0 or Citrix Presentation Server 4.5, or XenApp 5.0.

  4. The error message indicated in the Symptoms is displayed and the installation fails.

  5. Set the IPEC Policy Agent service for Windows 2000, or the IPSEC Services for Windows 2003, or IPsec Policy Agent for Windows Server 2008 to automatic.

  6. Restart the service.

  7. Install Presentation Server or XenApp 5.0 again. The installation succeeds.


Solution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.
Complete the following steps to fix the issue:

  1. Validate that the following?? listed services are started prior to installing Citrix Presentation Server 4.0, Citrix Presentation Server 4.5, or XenApp 5.0:

    • RPC (Remote Procedure Calls)
    • Server
    • Workstation
    • Windows Management Instrumentation Driver Extensions
    • IPSec (Presentation Server 4.0 or Citrix Presentation Server 4.5 or XenApp 5.0)
  1. In a scenario where IPSEC service?? must to be disabled, edit the following registry key to install XenApp with IPSEC?? service started and?? disable the dependency of IPSEC for the IMA service:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAService\DependOnService

  2. Remove the value "PolicyAgent".

After the server is rebooted, the IPSEC service can stop without interfering with IMA.

Problem Cause

The IPSEC service is not started and IMA Service depends on IPSEC.


Disclaimer

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

 

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